Symptoms

Customer pressed Recreate server button in CCP for his VPS. The VPS had a Plesk instance inside. The recreation failed on the first run and succeeded afterwards. Or, depending on the current OA version, it could be successful right from the start, but the error appears in /var/log/pa/vps.aps.log:

2017-06-16 08:07:11,238 aps_fd8eee25-d00c-4909-aa26-d3f206dbebfb_19 INFO  JerseyClientLoggingFilter [deferred] - 142 * [PACI->APSC] Client out-bound request
142 > POST https://127.0.0.1:6308/aps/2/applications
142 > x-paci-request-id: aps_fd8eee25-d00c-4909-aa26-d3f206dbebfb_19
142 > APS-Resource-ID: d29a9996-a0bc-44dc-8d91-d536348cf4a9
142 > Accept: application/json
142 > Content-Type: application/xml
{"aps":{"package":{"id":"7e1f9539-999d-4b0a-98bc-a2b5f0d8ace1"}},"panels":{"environment":{"aps":{"id":"d29a9996-a0bc-44dc-8d91-d536348cf4a9"}}}}

2017-06-16 08:08:16,698 aps_fd8eee25-d00c-4909-aa26-d3f206dbebfb_19 INFO  JerseyClientLoggingFilter [deferred] - 142 * [PACI<-APSC] Client in-bound response
142 < 500

Now Manage Plesk button gives error:

An unforeseen error occurred. Please contact root@osscore

Cause

Plesk instance got removed during server recreation, but the recreation itself faced an error. When it finally was successful, Plesk instance was not created again, since the relation with it was already gone. This behavior is acknowledged as CCU-14043: no fallback on recreation failure with PVPS.

Resolution

In order to provide a new Plesk Panel instance on the same VPS:

  • Go to the subscription resources limits in OA Provider's CP
  • Set PVPS_Panel resource limit to 0
  • Set the limit to 1 again
  • Wait for the Panel provisioning task to get completed

Sometimes a blank page may appear, when setting the resource limit to 1. Use the following article to resolve the problem in this case:

Increasing PVPS_Panel resource limit from 0 to 1 shows blank page

Contact Odin Technical Support in case of any more difficulties faced.

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