Symptoms
Error appears in Event Viewer Application log on each Windows node upon OA agent restart:
Log Name: Application
Source: POA
Date: 04/11/2014 07:24:05
Event ID: 6
Task Category: None
Level: Error
Keywords: Classic
User: HOSTING\pem_admin
Computer: WPE01.hosting.local
Description:
The description for Event ID 6 from source POA cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
It occurs on all Windows hosts. OA Agent actually works fine, so the issue does not affect provisioning. Agent version on all servers is up to date. The following error can be found in poa.log
on Windows servers when restarting OA Agent:
Nov 5 06:33:37 WPE01 : ERR [SYSTEM 0:42160:9ed4 lib]: [SDK::IPAddress::getHostIPAddressDescriptions] SDK::IPAddress: system exception, ID 'IDL:omg.org/CORBA/UNKNOWN:1.0'
Unknown vendor minor code id (0), minor code = 0, completed = YES
Nov 5 06:33:37 WPE01 : INF [SYSTEM 0:42160:9ed4 lib]: [SDK::IPAddress::getHostIPAddressDescriptions] Failed to narrow object IOR:010000001900000049444c3a495041646472657373507269766174653a312e300000000001000000000000009c000000010102490f0000003139322e3136382e35302e32303900e0a3204ef04800000014010f004e5550000000250100000001000000526f6f74504f41004f626a6563744d616e6167657273006368696566001f0000000100000053444b3a3a4950416464726573732f3302000000000000000800000001000000004f41540100000018000000010000000100010001000000010001050901010000000000
Nov 5 06:33:37 WPE01 : DBG [SYSTEM 0:42160:9ed4 lib]: [SDK::IPAddress::getHostIPAddressDescriptions] {module_id="Kernel"; code="10"} The operation can not be completed because the following component is missing or is not running: SDK::IPAddress (sc_name '', sc_id #3)
Nov 5 06:33:37 WPE01 : ERR [SYSTEM 0:42160:9ed4 pleskd]: [syncHostNICs] syncHostNICs has failed for host ID #48: user exception, ID 'IDL:Plesk/ExSystem:1.0'.
Cause
Discrepancy in service information between management and slave nodes.
Resolution
In order to resolve the issue, please proceed with the following steps:
- Stop OA Agent on all affected nodes using the command
net stop pem
Restart services on the Management Node using commands below:
service stop pem
service stop pau
service start pau
service start pem
- Start OA Agent on all affected nodes using the command
net start pem