Symptoms
Office 365 (CSP agreement) provisioning task fails with the following error in server.log
:
{"parameters":{"property_name":"password"},"code":"20017","error_code":"InvalidProperty","message":"Password is weak.","object_type":"Error"}
Cause
Software-related issue #APSA-14850: "Provisioning CSP customer received error message "password is weak".
Resolution
Contact Odin Technical Support to clarify the status of the issue.
Workaround for the issue: Wait for a few minutes and then resubmit the failed task.