Symptoms

When a customer is created in Microsoft cloud by Office 365 application the Bill-to section is not fully filled. As a result provider cannot see customers' subscription via Partner Center Portal until he fills this information.

During the provisioning endpoint sends the following request to Partner API:

2015-08-19 18:02:04,684 [  53] DEBUG commandRequest: Request data: {"customer":{"domain_prefix":"testuser123","user_name":"admin","password":"******","profile":{"email":"mail@mailserver.tld","culture":"en-US","language":"he","company_name":"test-company","default_address":{"first_name":"test","last_name":"surname","address_line1":"address","address_line2":"","city":"city","region":"city","postal_code":"49170","country":"il","phone_number":"xxxxxxxxxx"},"type":"organization"}},"type":"ResellerCustomerCreateCommand","reseller_id":"*************","tracking_id":"":"*************","","sales_admin_token":"$TOKEN"}

..........

"type":"ResellerCustomerCreateCommand",
"reseller_id":"xxxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxxx",
"tracking_id":"zzzzzzzzzzzzzz-zzzz-zzzz-zzzz-zzzzzzzzz",
"sales_admin_token":"$TOKEN",
"id":"yyyyyyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyy"
}

We are missing the first_name and last_name parameters in profile section.

Cause

The issue has been reported to developers as APSA-12406 'Bill-to' information is not filled when the customer is created by Office 365 application and fixed in Office 365 6.2.

Resolution

Please schedule update to Office 365 6.2 or higher to prevent the issue. The workaround is to add these details manually in https://partnercenter.microsoft.com.

Internal content