Symptoms

Office365 Provisioning Subscription task fails:

Partner with Id '1234' is not valid for Offer xxxxxxxx-xxxx-xxxx

Upon subscription provisioning, Office365 application sends the following CREST API request:

x-ms-tracking-id: b915574e-4724-4c12-8b5d-157b3fb4e665
{"line_items":[{"line_item_number":0,"offer_uri":"/160-......-6ae0/offers/5C9FD4CC-EDCE-44A8-8E91-07DF09744609","quantity":1,"advisor_partner_id":"713621"}],"recipient_customer_id":"ad37c8ab-xxxx-db7ed00dbec9"} 

It also passes advisor_partner_id parameter which is configured as MPN_ID attribute for reseller account on the Billing side. The request format is valid, according to the CREST API specification.

An error occurs on the Microsoft side, the response of the request is equal to the OA task output:

Response received on thread default task-27
< 403
< api-version: 2015-03-31
{"object_type":"Error","code":"OMS_6081","error_code":"AccessDenied","message":"Partner with Id '713621' is not valid for Offer '5C9FD4CC-EDCE-44A8-8E91-07DF09744609'"}

Cause

Reseller with specific advisor_partner_id in question is incompatible with the exact offer on the Microsoft side for some reason.

Resolution

Please, contact Microsoft support in order to resolve the issue.

Internal content