Symptoms
Office365 subscription does not react upon limits changing, but it is ok with APS events (checked KB 128809 article).
It was discovered, that Office365/Tenant/1.2
and pa/subscription/1.0
APS resources are in place and belong to the correct account, but there is no Office365/Subscription/1.2
APS resource, as it should be.
Cause
Missing /Office365/Subscription/1.2
APS resource due to manual Endpoint DB modification.
For example, license quantity was set to 0
in the Endpoint DB directly.
Resolution
Contact Odin Technical Support to re-create APS resource manually.