Symptoms
VPS tab does not load and shows Connection refused
error for all subscriptions.
The following request is shown in the web debugger:
GET https://domain.tld/aps/2/resources/916aaffb-722f-4197-98d8-29bc48de8fd7/status [HTTP/1.1 500 Internal Server Error 726ms]
The resource itself is fine:
# curl -kE /usr/local/pem/APS/certificates/poa.pem -X GET https://localhost:6308/aps/2/resources/916aaffb-722f-4197-98d8-29bc48de8fd7
{
"aps":
{
"type": "http://www.parallels.com/paci/vps-hosting/vps/1.0",
"id": "916aaffb-722f-4197-98d8-29bc48de8fd7",
"status": "aps:ready",
...
Cause
PACI-aps service is stopped for some reason.
Resolution
Start PACI-aps service on the OA Management Node:
# service PACI-aps start
Investigate the reason of the service outage per the logs available in /var/log/PACI
directory.