Symptoms

OSA platform has the history of 5.5 > 6.0 > 7.0 upgrades.

After the upgrade, it does not allow to change login for staff members, the error is shown in CCP:

Error!  The unknown error is occured. Please try to use another email as login or contact with support for assistance.

In /var/log/pa/core.log the following message can be seen:

Sep  1 15:05:09.972 : ERR [rest:469 1:23585:ac98cb70 SAAS 63736279]: [ APSC] REST Error: PUT /aps/2/application/rest/4b4022fe-5bd3-42fc-984f-db9cf2476150 code=500: 'memberId': can't update property marked as 'final'

It is not possible to change password of such users, the following error is shown:

SYSTEM_ERROR.DETAIL.CAPTION
Message: "com.parallels.pa.service.aps.exception.APSError from [Module "deployment.pui-war.war:main" from Service Module Loader]". 

Cause

The issue is recognized as APS-38141 (Cannot update login: 'memberId': can't update property marked as 'final', caused by incorrect order_num of memberId property).

During 5.5 > 6.0 upgrade, internal property memberId for staff member APS resources was set incorrectly.

Resolution

Contact Odin Technical Support to apply the fix in the OA database.

Internal content

Link on internal Article