Symptoms

Creation of a cloud server from an image has been initiated via the Customer Control Panel. It is stuck in "Creation in Progress" status for a long time.

No activity related to the creation of this server was found on the storage node and on the target node where the server is supposed to be created (in /var/log/parallels.log).

Cause

One of the probable reasons - stuck parallels-server process on the storage node.

Resolution

  1. Check /var/log/IM/PACI-im.log, /var/log/IM/PACI-vm2vf.log for any errors related to the stuck cloud server.
  2. Check the parallels-server process status on the storage and the target nodes:

    # service parallels-server status
    
  3. Try to telnet to these nodes on port 64000 locally and from Instance Manager. If the connection is established, make sure that the welcome message is shown like below:

    # telnet localhost 64000
    Trying ::1...
    Connected to localhost.
    Escape character is '^]'.
    PRL6.5.23235.977226 (Wed, 19 Feb 2014 12:59:28)
    

If the connection works, but the welcome message is not shown, parallels-server process could be stuck. In that case try to restart it:

# service parallels-server restart

If the restart is stuck as well, then kill the correspondent process and start parallels-server again:

#  service parallels-server start

After that the creation of the server should fail, and the stuck server will disappear from CCP. Please start the creation again after the above-mentioned steps are performed.

Note: before killing the parallels-server process, it could be useful to make a core dump of the process for further investigations using:

gcore <process_id>

Replace <process_id> with an actual process ID of the parallels-server process. This dump can be provided to Odin technical support to investigate why the process was stuck.

Internal content