Symptoms
After a successful upgrade order, subscription limits are increased on OA side, but stay the same in IM. CCP displays the old limits.
The following error appears in /var/log/PACI/paci.log
on OA core:
2016-01-02 22:58:28,077 -7847- INFO LoggingFilter [apsc(5)] - 29757 * [PACI<-IM] Client in-bound response
29757 < 406
29757 < Date: Sat, 02 Jan 2016 19:58:27 GMT
29757 < Content-Length: 62
29757 < x-paci-request-id: fec4678e-409c-4956-8e1e-3e84129427a5
29757 < server: grizzly/2.2.21
29757 < Content-Type: text/plain
29757 <
P80334: Cannot reduce backup limit below the current usage = 5
2016-01-02 22:58:28,079 -7847- ERROR ApsResourceHelperImpl [apsc(5)] - Error during upsell
java.lang.Exception: Failed to reconfigure server
There is a discrepancy in VPS backups: there are backups present in IM DB, but missing in APSC DB:
[root@osscore ~]# curl -uadmin:*** http://<oaci_im_ip>:4465/paci/v1.0/of/<customer_id>/ve/<ve_name>/backups/1970-01-01%2000:00%/2016-01-05%2010:37%2
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
<ve-backups>
<backup im-backup-id="160918" cloud-backup-id="{deef9611-122c-419b-a3c1-f67f6f12bc54}" schedule-name="daily" started="2015-12-21 03:11:14.796528+03" ended="2015-12-21 03:15:41.837387+03" successful="true" backup-size="6243186426" backup-node-name="node-name" ve-state="STARTED">
<description>scheduled</description>
</backup>
</ve-backups>
[root@osscore ~]# curl -X GET -E /usr/local/pem/APS/certificates/poa.pem -ksS "https://127.0.0.1:6308/aps/2/resources/ede58b42-ab7a-4606-ae2a-56e7ef38bb78/backups"
[
]
Such backups are listed in Provider's CP, but are missing in Customer's CP.
Cause
The issue is recognized under internal ID CCU-12120: backups usage differs between IM and APSC.
Resolution
- To avoid such issues in the future make sure that OA 6.0.6 HOTFIX 128188 or higher is installed.
- In order to fix the existing affected subscriptions, contact Odin Technical Support.