Symptoms

You are trying to upgrade Office 365 subscriptions from one service plan to another one by using the instruction provided in Odin Automation Office 365 Integration Provider's Guide >> Syndication Partner Scenario > Useful Information > How to Upgrade Office 365 Subscriptions through Provider/Reseller Control Panel and Odin Automation Office 365 Integration Provider's Guide >> Cloud Solution Provider Scenario > Useful Information > How to Upgrade Office 365 Subscriptions through Provider/Reseller Control Panel.

The Upgrade Subscriptions button is unavailable and some of the subscriptions have the following upgrade comment:

There are more than one active cloud subscriptions

Cause

The requirements provided in the upgrade instruction are not satisfied for the subscriptions:

  • Each subscription must contain one 'License' resource with a non-zero limit. If a subscription includes additional 'License' and 'Add-on' resources, their limits must be equal to zero.
  • The target service plan must contain one 'License' resource.

Resolution

Perform the following actions:

  1. Process each subscription with the 'There are more than one active cloud subscriptions' upgrade comment:

    1. Write down the identifier of the subscription.
    2. Write down the limits of the additional 'License' and 'Add-on' resources.
    3. Set the limits of the additional 'License' and 'Add-on' resources to zero through OA Billing Control Panel.
  2. Make sure the target service plan contains one 'License' resource.

  3. Perform the upgrade operation by using the upgrade instruction.

  4. Complete processing the subscriptions from step 1:

    1. Switch the subscription to a service plan which contain the 'License' resource and the additional 'License' and 'Add-on' resources through OA Billing Control Panel.
    2. Return the previous values of the limits of the additional 'License' and 'Add-on' resources through OA Billing Control Panel.

Internal Content

See this article.