Symptoms
Office365: 'Provisioning "AsyncOperation' task failed: Access Denied. Error Code: 0x0e22b5a8.
"code": 500,
"message": "Server returned a fault exception: [-1]
(Access Denied. \nError Code: 0x0e22b5a8.\nReport ID: 690588)",
"additionalNonlocalizableMessage": "",
"error": "ApplicationUnknownError",
"http_request": "POST /mosi5/aps/asyncOperations to 'mosi-endpoint.provider.com'"
}
In sitelog GetOrder_API
method returned the following error:
<name>Method</name>
<value>
<string>GetOrder_API</string>
</value>
...
<value>
<i4>2184521</i4>
</value>
...
<name>faultCode</name>
<value>
<i4>-1</i4>
</value>
Also, using Report ID: 690588
from the initial task output, we can check corresponding Problem Report
in BA for the following lines:
[16-08-04 BM_Object] +++[0] ItemResult* BM::GetOrder_API(Int)(4243279)
[16-08-04 generic_wor] [52253] Loading readonly a row (OrderID=4243279) in table SalesOrder
[16-08-04 BM_Object] ...[0] *** INTERRUPTED BY EXCEPTION *** ItemResult* BM::GetOrder_API(Int)
Cause
No such Order with ID #4243279 on the BA side. Perhaps, the order was archived or removed from BA DB manually.
Resolution
Please, contact Odin Technical Support to apply workaround for this case.