Symptoms

In NG Web Cluster inside webspace error_log and access_log do not have timestamps:

  • access_log:

    1.2.3.4 - - [27/Jun/2015:18:10:23 +0200] "GET     /folder_name1/folder_name2/shapeimage_1.png HTTP/1.1" 200 160 "http://www.domain.tld/folder_name3/Welkom.html" "Mozilla/5.0 (Linux; U; Android 4.3; nl-nl; ME302C Build/JSS15Q) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Safari/534.30" www.domain.tld
    
  • error_log:

    File does not exist: /var/www/vhosts/XX/XXXXXX/webspace/httpdocs/tld/robots.txt
    File does not exist: /var/www/vhosts/XX/XXXXXX/webspace/error_docs/404.html
    File does not exist: /var/www/vhosts/XX/XXXXXX/webspace/httpdocs/tld/favicon.ico, referer: http://www.domain.tld/
    

Cause

This issue is common in CloudLinux 6. Internal issue with id POA-86934: 'error_log in NG do not contain usual for apache logs headers' has been submitted to the Maintenance Team.

Feature Request with id POA-89640: 'Access log format and error log level on per webspace basis in NG cluster' will be considered for implementation in future versions of OA.

Resolution

Please Contact Technical Account Manager or Pooled Technical Associate team to get the status of the the requests mentioned above.

It was clarified with Cloudlinux that PHP-related errors in the error_log files cannot be time-stamped. These errors are reported by PHP into stderr and this output is redirected to the error_log file.

The issue with php time stamps could be fixed by checking missing files that are reported by php. Also you may modify the php.ini file in order to redirect php errors to another log file. For example, you may change the line error_log = syslog in php.ini file for these purposes.

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