Symptoms

O365 subscription transfer fails:

APS application has multiple resources directly associated with the old owner

Cause

Domain which is connected to services of O365 subscription is bound to another subscription. That could be checked in Provider's CP or Customer's CP:

  1. Choose the domain in question;
  2. Switch to "DNS" tab;
  3. Check value in "Subscription" field.

Resolution

There could be three cases:

  1. Domain is associated with dedicated DNS hosting subscription. Solution: add domain subscription to the transfer list.

  2. Domain is associated with another O365 subscription which cannot be moved. Solution: detach domain from incorrect subscription and attach again to one we will transfer.

    1. Ensure, that domain is hosted internally.
    2. Switch domain hosting type to "External".
    3. Switch domain hosting type back to "Internal". You will be asked about subscription the domain to be attached, chose the correct one.
    4. Retry the subscription transfer procedure.
  3. DNS hosting subscription is empty because DNS hosting type is external. Solution: switch it to Internal and choose right DNS hosting subscription like in scenario above.

It is also useful to check limits on DNS Hosting resource type and add/increase it via pem.setResourceTypeLimit or via BA if needed.

Internal content

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