Symptoms
Office365 subscription synchronization fails with the error:
1234567 - Error: Customer xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx has no offer 'PROJECTCLIENT' provisioned
Cause
Corresponding subscription is disabled on the OA side:
OfferId: 5dbd1579-34b6-445c-a93a-efd8371c9b05, SubscriptionId: yyyyyyy-yyyy-yyyy-yyyy-yyyyyyyyyyyyc, Status: Disabled, Quantity: 0, Usage: 0
But on the MOP side 2 licenses are still assigned to users:
> Get-MsolAccountSku -TenantId 53******-********-*********3e
AccountSkuId ActiveUnits WarningUnits ConsumedUnits
------------ ----------- ------------ -------------
syndication-account:ENTERPRISEPACK 10 0 10
syndication-account:PROJECTCLIENT 0 0 2
So in OSA the limit of these licenses in the subscription is now zero, but in Microsoft canceled licenses are kept for 90 days.
Resolution
- for each license press
Reconcile now
in MOP and follow the wizard to remove the license from the user - Repeat the synchronization attempt (or resubmit failed task)