Symptoms

Office365 provisioning task fails:

Provisioning: resource 94e7xxxx-ce5e-4d7b-a99e-7d0b918bda8a of type 'subscriptions' for APS application 'Microsoft Office 365-6.1-105': Request error: 500 Internal Server Error.

Body: {
"code": 500,
"message": "Use limit is exceeded for Offer id '5C9FD4CC-EDCE-44A8-8E91-07DF09744609'",
"additionalNonlocalizableMessage": "",
"error": "ApplicationUnknownError",
"http_request": "POST /O365App/aps/subscriptions"
}

The following error is returned from Microsoft (check Office 365 sitelog):

{"object_type":"Error","code":"OMS_7006","error_code":"OfferUseLimitExceeded","message":"Use limit is exceeded for Offer id '5C9FD4CC-EDCE-44A8-8E91-07DF09744609'"}

Cause

According to Microsoft policy, some Office365 offers are concurrent, which means that one customer (tenant) can only have no more than two subscriptions with that offer. The examples of concurrent offers:

  • Office 365 Business
  • Office 365 Business Essentials
  • Office 365 Business Premium

Such offers can be checked using Microsoft Offer Matrix downloaded from the Microsoft Partner Center portal.


real-life example: Customer already had Office 365 Business Premium license provisioned before. Currently this subscription has Terminated\Removed status on the OA side, which allows customer to place a new order for the same offer. But there is a, so called, grace period on the MS side when subscription is having Suspended status for ~90 days long, but still bound to this customer. Thus Microsoft provides an opportunity to restore subscriptions, but prevents new subscriptions creating from the OA side - concurrent offers conflict.

Resolution

  1. Cancel current Office 365 Sales Order;
  2. Make sure that all Unprovisioning tasks in task queue are successfully completed for subscription;
  3. Import subscription from the Microsoft cloud by using Office 365 Import Procedure