Symptoms
Execution of upgradeAPS1ToAPS2.py
on Office 365 subscriptions fails with the following error:
Offer limits in POA and in Gateway don't match. POA offer limits: {'8283970d-3cba-429c-9c75-eb7d33ec0f14': 1}; Gateway offer limits: {u'8283970d-3cba-429c-9c75-eb7d33ec0f14': 1, u'96b36813-d5e2-46b2-b111-41d84f9570d8': 1}.
The possible reason is a wrong add-on configuration. Please check the add-on Resource Types.
Cause
The error means that there is a discrepancy between OA and MS resources. In the example above, OA subscription includes Office 365 Business Essentials
resource type only, which corresponds to the MS offer ID 8283970D-3CBA-429C-9C75-EB7D33EC0F14
. However, the same account in Microsoft cloud also owns a Office 365 Business Premium
subscription with MS offer ID 96B36813-D5E2-46B2-B111-41D84F9570D8
.
Resolution
Include Office 365 Business Premium
resource type into the subscription on the OA side.