Symptoms

On attempt to perform O365 user synchronization in CCP, the following error message appears:

Completed synchronization.
Updated 1 user(s):
- `user@example.com` does not have role **User** assigned on top **Users** tab.
Failed to update 1 user(s):
- admin@example.com ('login' and 'password' properties must not be modified)

Cause

Login or (and) password discrepancy between MOP and OA. Passwords are not synchronized from the Microsoft Online Services Portal to Odin Automation.

Please, refer to the Synchronizing Office 365 Organization with Microsoft Online Services Portal section for additional information.

Another possible reason is that user user@example.com does not have role User assigned on the top Users tab.

Resolution

Check login (including the subdomain part) and password of the affected user(s) on the OA and MOP sides - they should be equal.

Otherwise, in case if role is not assigned on the top Users tab - assign it manually.

Internal content

Link on internal Article