Symptoms
CCP > Microsoft Office 365 tab throws SSL exception error on OA environment with Windows-based Management Node.
Cause
PAU service was restarted, while PEM service was not. After that SSL exceptions started occurring on all requests from APSC to POA-Core-Services. The issue has been reported to the development team as APS-28085: persistent 'SSL Exception' on request to POA-Core-Services after PAU restart.
Example:
Aug 19 22:48:23 PEMMN01 : INF [rest:4 1:18580:4ac4 SAAS 1281360578]: [ HTTP] OUT 192.168.33.131 [0] "GET /poa/subscriptions/32837b7a-2825-4918-88fa-0c5315ad9a20/resources?limit(0,1000) HTTP/1.0" [0] "" 15ms
Aug 19 22:50:59 PEMMN01 : ERR [openapi:192.168.33.180:42 1:18580:3e24 SAAS 1281369862]: [ APSC] REST Error: POST /aps/2/resources/2a5e44e0-43f2-4cd3-b5c7-207f5fa2af8f/domains code=500: Network error: SSL Exception: error:14092105:SSL routines:SSL3_GET_SERVER_HELLO:wrong cipher returned
APSC still kept "dead" connection, or some its parameters.
Resolution
Please contact your TAM or PTA to trace the status of APS-28085. As a workaround, please restart PAU and PEM services in a proper way:
- Stop PEM service
- Restart PAU service
- Start PEM service