Symptoms
The product license fails to update. The following errors may occur:
Licensing Server Unreachable: Unable to connect with licensing server.
Please make sure that your network allows communication to keys.odin.com:5224.
For more details check system help pages.
or
Couldn't resolve host name
or
Can't connect to keys.odin.com:5224 (Timeout)
Cause
The product tries to connect to the license server keys.odin.com
at port 5224 to update the license, but it cannot establish a connection.
Resolution
On April 4, 2016, the IP address of the license server was changed to 52.29.203.196. Make sure that the hostname keys.odin.com
resolves to the proper IP from your server:
# nslookup keys.odin.com
Address: 52.29.203.196
If the license server does not resolve to the correct IP, check the /etc/hosts
file.
If any of these servers are behind a firewall and old IP address of Key Administrator is listed in the firewall rules, please add new IP address of Key Administrator to the firewall rules to allow your servers to connect to keys.odin.com
. This can be checked with these commands, depending on your OS:
Linux:
# nmap -P0 -p5224 keys.odin.com
# telnet keys.odin.com 5224
# traceroute keys.odin.com
Windows:
telnet keys.odin.com 5224
tracert keys.odin.com
Note: Telnet Client should be installed additionally for Windows -> how to install Telnet Client
If you are using the APF firewall, check /etc/apf/allow_hosts.rules
for the mentioned IPs or the hostname keys.odin.com
.
OA-license can have incorrect URL of KA-server:
[root@linmn tmp]# curl -k -E /usr/local/pem/APS/certificates/poa.pem 'https://127.0.0.1:6308/aps/2/resources/?implementing(http://parallels.com/aps/types/pa/productLicense/1.1)' 2>/dev/null |egrep 'serverUrl|keyId'
"keyId": "PA.XXXXXXXX.0001",
"serverUrl": "https://ka.parallels.com:5224/xmlrpc",
In this case OA tries to connect to incorrect server and license update fails.
To fix it, download the license key from Odin KA and re-upload it in PCP. Then double-check license APS-resource.