Symptoms
An account received Overdue Balance
notification but this account does not have any overdue invoices.
Cause
Overdue Balance
notifications are sent by the method FindNotifiableAccounts
which is called daily in scope of daily billing process. It does not check the due dates of the documents (such check is performed when account is put on hold), it only checks the current account balance. If the accounts balance is negative, notification is sent out. Basically check is done with query below:
SELECT "A"."AccountID" FROM "Account" "A" CROSS JOIN "AccountBalance" "AB" WHERE (((("A"."NextCBNotifDate" < $1) AND ("A"."VendorAccountID" = $2)) AND ("AB"."AccountID" = "A"."AccountID")) AND ("AB"."Balance_Value" > $3)) AND ((("A"."AStatus" <> $4) AND ("A"."AStatus" <> $5)) AND ("A"."AStatus" <> $6)) ORDER BY "A"."AccountID" DESC
$1 - todays date
$2 - vendor id
$3 - zero
$4 - 12 (full hold account status)
$5 - 10 (credit hold)
$6 - 2 (cancelled)
NextCBNotifDate
is changed after the notification is sent out, date set depends of the setting Overdue Notification Interval (Days)
.