Symptoms

Task ID                      24821484
Queue name               domain_service393567
Task name                Export certificate for domain service with ID 393567
Task description         Task that exports certificate for domain service with ID 393567
Subscription ID              23146
Queue status                 Failed
Start not earlier than       Oct-24-2014 18:52
Method name              taskExportCertificate on OBJREF:apache:0:getDomainService:393567
Last execution output        Destination host 'service-node-01.ng.provider.com' (#1884), IP '10.184.18.72' : truepath /var/www/vhosts/8/120128/webspace/certs/httpsd.pem_ca: No such file or directory (errno 2).

Cause

The issue is related to software defect #POA-89222

After webspace migration from one NFS volume to another, apache certificate path still points to old NFS volume.

[root@hostname]# ll /var/www/vhosts/8/120128/webspace/certs/httpsd.pem_ca
[root@hostname]# ls: cannot access /var/www/vhosts/8/120128/webspace/certs/httpsd.pem_ca: No such file or directory

plesk=> select * from  apache_h2e_ws_to_mpoint_affinity where homedir_id = 120128;
homedir_id | mpoint_id
-----------+-----------
 120128    |         1
 (1 row)

[root@hostname]# ll /var/www/vhosts/1/120128/webspace/certs/httpsd.pem_ca
-rw-r--r-- 1 root root /var/www/vhosts/1/120128/webspace/certs/httpsd.pem_ca

Path to the certificate is incorrect in the system database.

Resolution

The issue is fixed in OSA 5.5.9

Please install required update. To correct existing inconsystency please contact Odin Tecnical Support.

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