Symptoms
Customer cannot access CP with error: "Member # does not exist." Account (staff member) exists only in BA, but not in OA.
Existing BA subscriptions stucks in 'Ordered'-'Not Provisioned' status, Payment Order is 'Waiting for payment'.
Cause
For some reason, task on account (staff member) creation in OA failed (OA was not available, or incorrect parameters passed from BA). This can be found in BA CP:
System - Settings - Events - Account Created - Event ID*** - Event log
Execution Failed: Operations Automation is not available. Connection to * has failed: Connection timeout. Please check network settings.
And for User creation: System - Settings - Events - User Created - Event ID*** - Event log
ExceptionResult: Parallels Operations Automation error #error_code #0, extype_id #2, module_id #Common, Invalid parameter: Invalid set of parameters. There should be specified EITHER external_identity OR auth, person, address, phone, [fax], email...
This means that one of the mandatory contact details is empty.
Resolution
For Account: Make sure network issues are resolved, resubmit failed event.
For User: Verify that all mandatory contact information fields are filled with correct data for User on BA side:
Home - Customers - Users tab -
If for example email address is empty - fill in valid email address. Please verify all fields, marked with *
After correction, please resubmit failed event.