Symptoms
When customer accesses File Manager in CP, he receives an error:
Unable to connect to backend.
The error occurs for a single webspace that hosts a large amount of files. Other subscriptions are not affected.
Cause
It takes a huge amount of time to scan through the webspace files, and the default web server or PHP timeouts are not enough to serve the request.
Resolution
Increase the possible timeouts:
Linux File Manager.
Apache web server:
- Edit
timeout
value in/etc/httpd/conf/httpd.conf
Reload Apache configuration:
# service httpd reload
- Edit
PHP:
- Edit
max_execution_time
in/usr/local/pem/sysvhosts/elFinder/conf/php.ini
Reload Apache configuration:
# service httpd reload
- Edit
Note, in case File Manager is deployed on an NG cluster, the above settings should be configured on all servers in the cluster.
Windows File Manager.
IIS web server:
- Open Internet Information Services (IIS) Manager and expand Sites list.
- Select File Manager Web Site and click Advanced Settings in the Actions pane.
- Expand Behaviour tab and set the desired value for "Connection Timeout" field.
PHP:
Edit
max_execution_time
inC:\Program Files (x86)\SWsoft\PEM\sysvhosts\elFinder\conf\php.ini
and ensure that the activityTimeout does not override it - check official IIS documentation for details.Command to add/increase activityTimeout:
%windir%\system32\inetsrv\appcmd set config -section:system.webServer/fastCgi /[fullPath='C:\php\php-cgi.exe'].activityTimeout:600