Symptoms

Service user is shown only in Provider Control Panel, but is not shown in Customer Control Panel. Why such situation occurs and how to delete such user?

Cause

Such situation could occur due to 2 reasons:

  1. some misconfiguration, e.g. canceled/deleted tasks.
  2. subscription was destroyed by PBA-E but APS 2.0 enabled service user delete operation task was cancelled by provider.

Resolution

  1. First of all, it is necessary to obtain user ID as it is not shown in POA GUI. It can be done using the API method pem.getUserByLogin. You may use the following Python script on the management node to do it (put needed login name there):

    from poaupdater import openapi, uLogging
    
    uLogging.log_to_console = False
    
    api = openapi.OpenAPI()
    result = api.pem.getUserByLogin( login = 'user123@hosting.local' )
    
    print result
    

And run the script to get corresponding user ID

[root@poa API]# python pem.getUserByLogin.py
{'user_id': 123}
  1. Then we need to use API method pem.removeUser. As in the example above, please create Python script for this method:

    from poaupdater import openapi, uLogging
    
    uLogging.log_to_console = False
    
    api = openapi.OpenAPI()
    result = api.pem.removeUser( user_id = 123 )
    
    print result
    

And run the script from the management node (method returns 'None' in case of successful execution) :

[root@poa API]# python pem.removeUser.py
None
[root@poa API]#

For APS 2.0 enabled service user the actions should be following

1.Check cancelled task and run it.

2.If task failed due to following error

Last execution output   
Internal error:
404 Not Found
[ApplicationUnknownError] Resource with UID '205c18a1-18df-40dc-8d58-9b6247cd03f1' not found..

Body: {
"code": 404,
"message": "Resource with UID '205c18a1-18df-40dc-8d58-9b6247cd03f1' not found.",
"additionalNonlocalizableMessage": "",
"error": "ApplicationUnknownError"
}

Contact Odin technical support team to resolve the issue.

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