Symptoms

Task name       Restore 'Webspace "d1234567.hosting.tld"' from group 'group_name'
Method name     taskRestoreBackupData on SCREF:BackupManager:0
Last execution output   Destination host 'host001.domain.com' (#1234), IP '1.2.3.4' : Cannot parse tar archive: ackgroun: invalid number.

Cause

Tar-archived backup file is corrupted. It could happen due to file system error or some network issue during backup creation.

Resolution

  1. Find the backup file location

    plesk=> SELECT group_id,group_name,store_dir,host_id FROM backups_groups where subscription_id =1234567;
     group_id |        group_name        |  store_dir  | host_id
    ----------+--------------------------+-------------+---------
         6875 | group_name               | /pembackups |    1234
         6874 | group_name2              | /pembackups |    1234
        (2 rows)
    

    From the task output we see backup group name is 'group_name'.

    plesk=> SELECT backup_id,object_name FROM backups_backups where group_id in (6875);
         backup_id |                   object_name
         ----------+-------------------------------------------------
             14657 | MySQL Database "db1234567_test"
             14658 | MySQL Database "db1234567_miclub"
             14656 | Webspace "d1234567.hosting.tld"
            (3 rows)
    

    Go to the host #1234 where backup file resides.

    [root@backupnode1 ~]# ll /pembackups/*14656*
    -rw-r----- 1 root root 69157376 Oct 29 15:09 /pembackups/backup_data-14656.tar
    
  2. Copy backup file to some temporary folder and check if it can be extracted:

    root@backupnode1 ~]# tar -xvf backup_data-14656.tar
    tar: Removing leading `/' from member names
    tar: Skipping to next header
    tar: Archive contains obsolescent base-64 headers
    ...
    tar: Error exit delayed from previous errors
    

    We can see the archive is broken.

  3. Check how many files are extracted from the archive. Compare it with a number of files in corresponding webspace. Use command like below:

    ls -lRa var/www/vhosts/1/109849/webspace/ |wc -l
    7811
    

    Analyze if it is worth to restore from the backup or it is better to leave existing content in webspace. In second case cancel the task and remove the backup from OA Customer Control Panel. If you decide to restore from archive use following procedure:

    1. Create new tar-archive with the same name backup_data-14656.tar from files extracted at Step 2 above. Make sure backup contains valid paths to files:

      tar -tvf filename
      
    2. Replace broken tar-file in /pembackups/ and restart failed task.

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