Symptoms

Task Send link for change password fails with error Connection timed out: can not connect to host smtp.hostname.com:25, for example:

Task ID           1111111
Task name         Send "Send link for change password" mail to user test
Task description  Task that sends a "Send link for change password" mail to user@domain.com for user test (1123456)
Queue status      Failed
Method name       taskSendLocalizedEMail on SCREF:Notifier:0
Last execution output  Connection timed out: can not connect to host smtp.hostname.com:25

Cause

SMTP server that OA uses to send email notifications does not work or there is connectivity problem.

Resolution

  1. Check which SMTP server is used by OA to send notifications:

    For OA 5.4 and earlier:

    Open OA provider Control Panel and navigate to the System Director > Configuration Manager > Service Controllers > MailMessenger > Configuration

    For OA 5.5 and later:

    Open OA provider Control Panel and navigate to Infrastructure > Service Controllers > MailMessenger > Configuration

  2. From OA core telnet to port 25 on SMTP server and try to send test email. In case of Connection timed out error most likely reason is that OA core cannot connect to port 25 on SMTP server. Make sure that SMTP server does listen on port 25 and network/firewall/routing settings allow OA core to access this port.

    The most common mistake is that public IP address of SMTP server is specified (or hostname that resolves to public IP address). OA core has access only to backnet so it will not be able to connect to public IP. In this case one needs to specify backnet IP that is reachable by OA.

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