Symptoms
The task Wipe device with PIN fails with the error:
Task ID 112356
Task name Wipe device with PIN='28A8C847' of BlackBerry account 'user@domain.com' (id=XXX)
Task description Wipe device with PIN='28A8C847' of BlackBerry account 'user@domain.com' (id=XXX)
Queue status Failed
Start not earlier than Oct-31-2013 13:11
Method name wipeBesDeviceHandler on OBJREF:Exchange:0:getBESServiceProviderDummy:0
Last execution output BlackBerry Mobile Account with account_id = XXX not found.
Cause
The Blackberry account with the ID mentioned in the failed task was removed by another OA task.
Resolution
Search the same task queue in OA Task Log (filter tasks by the related Subscription ID), there should be the processed 'Destroy BlackBerry account' task for the BlackBerry account with the same ID like in the example below:
Task ID 1807431
Task name Destroy BlackBerry account 'user@domain.com' (id=XXX)
Task description Destroy BlackBerry account 'user@domain.com' (id=XXX)
Queue name DomainService00004470
Method name destroyBesAccountHandler
Execution status Successful
Incorrect order of tasks processing is likely caused by temporary cancellation of the first task (112356) that allowed next one (1807431) to proceed and delete BlackBerry account.