Symptoms

Customer tries to add new OS template via OA > Services > Cloud Infrastructure > Virtualization Nodes > node hostname > OS templates > Discover OS templates > OS template name > Finish. The OS template is not added, and the following error can be found in Tasks -> Cloud Infrastructure Log:

Specify an existing folder and try again

The following errors are found in /var/log/parallels.log on the node:

05-28 12:01:28.906 F /disp:7911:984420/ Processing command 'DspCmdGetHostCommonInfo' 2048 (PJOC_SRV_GET_COMMON_PREFS)
05-28 12:01:28.968 F /disp:7911:984420/ Processing command 'Unknown' 2170 (PJOC_SRV_GET_DISK_FREE_SPACE)
05-28 12:01:28.970 F /disp:7911:984420/ CFileHelper::GetDiskAvailableSpace(/var/parallels/backups) failed : 0x80000324 PRL_ERR_INCORRECT_PATH
05-28 12:01:29.611 F /disp:7911:492439/ Processing command 'DspCmdUserGetLicenseInfo' 2081 (PJOC_SRV_GET_LICENSE_INFO)

Cause

Missing directory /var/parallels/backups on virtualization hardware node.

Resolution

The issue has been reported to the development team as a bug CCU-7220. Please contact your Account Manager to trace the status of the issue. As a workaround, please create the directory /var/parallels/backups on the required hardware node.

Internal content