Symptoms

Attempt to upgrade Exchange organization whether by changing service template or using Upgrade to Newer Exchange Version button fails with the error:

Cross-domain migration for Exchange subscription 1234567 is not possible because it contains emails on following shared domains: domain1.tld:domain2.tld. Remove all emails on shared domains firstly and repeat the operation.

Or:


Could not upgrade organization '***' to newer Exchange version. Cross-domain migration for Exchange subscription 1005652 is not possible because it contains emails on following shared domains: domain1.tld. Remove all emails on shared domains firstly and repeat the operation.


Cause

There could be several reasons for this error:


1. Customer has email addresses for mailboxes based on provider's shared domain. Due to limitation and migration complexity, it is not possible to migrate organization in case if such addresses are present (refer to documentation for details).

2. Email addresses are based on non-shared domain added to distribution list. However, the domain is not added to Odin Automation or does not have Exchange hosting enabled.

3. Email addresses of hidden contacts (used for mailbox forwarding) are based on redundant instant access domain name.

Resolution

List of resolutions for corresponding points provided above:


1. Check if customer has any email addresses based on shared provider's domains (refer to Providing Hosted Exchange in Shared Domains documentation in order to obtain additional information about shared domains). If such addresses are found, it is required to remove them. They could be restored right after migration is finished.

2. Add domain from the error using Add Existing Domain Registered Elsewhere button and enable Exchange hosting for this domain.

3. Hidden contats are used for internal purpose only and not available for modification by a provider or acustomer. Contact CloudBlue Technical Support in order to apply internal workaround for the issue.


Internal content

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