Search Engine: Elastic

Article ID: 125344, created on Apr 30, 2015, last review on Jun 20, 2018

  • Applies to:
  • Business Automation

Symptoms

Last billing date of the account is outdated, there is no monthly invoice for the consolidated account, attempt to bill the account manually results in the error:

Account #ID billed with errors.

In the log one of the errors below can be seen:

    Payment Method is Deleted. It can not be used for Payments now.

    Payment Method is Expired. It can not be used for Payments now.

    Specified payment method is not configured. Please select a payment method from the list.

Cause

The reason of the issue is a bug with id #PBA-61289 ("Consolidated account billing fails: "Payment Method is Deleted. It can not be used for Payments now.""). The customer used to have a default payment method which was later deleted, but the system attempts to create a payment with this deleted method.

Resolution

To workaround an issue please pay the affected orders with one of the available configured payment method.

caea8340e2d186a540518d08602aa065 e12cea1d47a3125d335d68e6d4e15e07 198398b282069eaf2d94a6af87dcb3ff

Email subscription for changes to this article
Save as PDF