Symptoms

During PBA-E 5.4 update installation PBA-E hotfix installer script is executed:

== Start PBA hotfix autoinstaller (Version: 1) (log:/usr/local/bm/log/pba_hotfixes.log, cache:/usr/local/bm/pba_hotfixes) ==

However it fails with 500/Internal Server Error:

Detect PBA version: 5.4.17-006 ...

Retrieving new version of autoinstaller (http://download.pa.parallels.com/pba/5.4/pba-hotfixes.pl) ...

[FAILED] : Response: 500/Internal Server Error

Retrieving list of hotfixes for PBA 5.4 (http://download.pa.parallels.com/pba/5.4//hotfixes.list) ...

[FAILED] : Response: 500/Internal Server Error

Finish PBA 5.4 hotfix autoinstaller ...

Cause

Internet access is filtered by the firewall:

#telnet download.pa.parallels.com 80

.........

Resolution

1) Disable firewall, verify web resource availability.

2) Stop PBA-E services if running:

#service pba stop

3) Launch PBA-E hotfix installer manually:

# cd /usr/local/bm/tools/

# ./pba-hotfixes.pl install

Make sure that no 500/Internal server error appears:

Detect PBA version: 5.4.17-006 ...

Retrieving new version of autoinstaller (http://download.pa.parallels.com/pba/5.4/pba-hotfixes.pl) ... [SKIP]

Retrieving list of hotfixes for PBA 5.4 (http://download.pa.parallels.com/pba/5.4//hotfixes.list) ... [DONE]

4) Start PBA-E service after hotfix installation complete:

# service pba start

Internal content