Symptoms

After upgrade to PBA 6.0.1 the susbcriptions are renewed for a wrong period - for example, the customer chooses 2-year-period, but an order is generated for 1 year only.

Cause

The issue is caused by the product bug with id #PBA-61969, the default period is taken from the service plan instead of an actual one.

Resolution

Install the hotfix - https://kb.cloudblue.com/124683.

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