Symptoms

Tasks related to Windows file manager fail with the following error:

Queue name  domain_service1001
Task name   Create access for Windows Files Manager for domain service (ds_id=1001, hd_id=100001) on host 'web01.provider.tld' (host_id=101).
Task description    Create access for Windows Files Manager for domain service (ds_id=1001, hd_id=100001) on host 'web01.provider.tld' (host_id=101).
Last execution output   User for Windows File Manager is not found in home directory (hd_id = 100001)

Another example:

Turn on FTP access for Hosted Service User 481572 on host '<FQDN>' (host_id=<HOST_ID>, sub_id=<SUBSCRIPTION_ID>, wb_id=<WEBSPACE_ID>, user_name=<USER_NAME>).

Reactivating Windows File Manager solves the issue.

Cause

The method attachWinFMToHSU called in the scope of this task updates the Operations Automation system database with the value of srv_id not equal to NULL. However, OA expects NULL:

DBG [1:25884:b0423bb0:14 1:25884:b0423bb0 lib]: CORBA_POAUI:bbc723e827cec7aa5dbfd833d4189227 <1> IDL:Plesk/WinFileManager/sc_private:1.0::attachWinFMToHSU
DBG [1:25884:b0423bb0:14 1:25648:af03dbb0 Kernel]: STMT [Con: 13329, 0xa9f0ff08 txn:3352884] ' INSERT INTO  iis_fm_users  (  hd_id ,  ops_scheduled ,  srv_id ,  sync_status ,  user_id  ) VALUES (  ?, ?, ?, ?, ? )'($0 = 100001, $1 = 1, $2 = 1001, $3 = 1, $4 = 10001)

When File Manager is reactivated, another method is called:

DBG [1:25884:b0423bb0:1 1:25884:b0423bb0 lib]: CORBA_POAUI:989fa980d931234cee7a06838bfcc969 <1> IDL:Plesk/WinFileManager/sc_private:1.0::provide
May 20 10:12:52 osscore : DBG [1:25884:b0423bb0:1 1:25884:b0423bb0 WinFileManager]: [WinFileManager::WinFileManager_impl::provide] ===> ENTRY

This adds the NULL value of srv_id to the OA database, correcting the issue:

DBG [1:25884:b0423bb0:1 1:25648:af03dbb0 Kernel]: STMT [Con: 16260, 0xb258a358 txn:3421373] ' INSERT INTO  iis_fm_users  (  hd_id ,  ops_scheduled ,  srv_id ,  sync_status ,  user_id  ) VALUES (  ?, ?, ?, ?, ? )'($0 = 100001, $1 = 1, $2 = NULL, $3 = 1, $4 = 10001)

Resolution

The issue has been resolved since POA 5.5 update 1 because File Manager has been replaced: see the POA 5.5.1 release notes.

To fix the issue, please update your environment to POA 5.5 update 1 or later. To work around the issue on older versions, cancel the task and reactivate File Manager from the Customer Control Panel.

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