Symptoms

"Default Subscription Period" ( Home > Products > Service Plans > PlanID > Publication Settings) is set, store is synchronized but in the on-line store a different subscription period is selected by default and put in the order cart.

Cause

The issue is caused by the bug with id #PBA-52960. The bug is reproducible when the parameter SINGLEPLAN_EDIT is set to true on the store screen (one service plan in the sales category).

Resolution

As a workaround use Sort Number in the subscription periods settings (periods without the sort id are on the top, then in ascending order) or reconfigure the store so that the bug above is not reproduced.

Internal content