Symptoms

Attempt to "Update Contacts" for domain (PBA Home > External Systems Director > Domain Manager > Domains > domain_name > Manage Contacts in PBA-E 5.4 and earlier or Services > Domains > domain_name > Manage Contacts in PBA-E 5.5 and later) fails with error:

Update of contacts for domain domain.tld failed: Unknown error while calling plug-in container. Could not update contact. Reason: Domain contact could not be updated..

Same error can be seen in domain refistrar log.

For example if domain is registered with InternetX, the following request and response can be seen in /usr/local/bm/log/INTERNETX.log:

[14-02-28 21:11:12.508 Worker1.230 TH05302 NTE] Request:
<?xml version="1.0" encoding="UTF-8"?>
<request><auth><user>***</user><password>***</password><context>***</context></auth><client>PBA 5.0.1 20110708</client><task><code>0302</code><handle><id>14169658</id><organization>Zak<C5><82>adUs<C5><82>ug test<C5><9A>wider</organization><address>test</address><pcode>25-123</pcode><city>Kielce</city><country>pl</country><phone>+48--123456</phone><email>test@gmail.com</email></handle><reply_to>devnull@autodns2.de</reply_to></task></request>

[14-02-28 21:11:12.508 Worker1.230 TH05302 NTE] Response:
<?xml version="1.0" encoding="utf-8" ?>
<response>
  <result>
    <msg>
      <code>EF03010</code>
      <object>
        <type>phone</type>
        <value>+48--123456</value>
      </object>
      <text>Invalid Phone number.</text>
      <type>error</type>
    </msg>
    <status>
      <code>E0302</code>
      <text>Domain contact could not be updated.</text>
      <type>error</type>
    </status>
  </result>
</response>

Cause

Exact cause should be seen in Response from registrar.

In above example contacts can not be updated becasue of "Invalid Phone number" - phone number of new contact has wrong format.

Resolution

Check regisrtrar log for exact error. Check new contact information for consistency.

Internal content