Symptoms
For some resellers each Billing or Sales order stays in New status and there are no invoices created.
Cause
The issue can be caused by the customized Order Flow for the reseller in question.
Resolution
It is necessary to verify Transition Type for the transaction in Order Flow of the Order in question in
System > Settings > OrderProcessing > All Order Flows > [order_flow_that_reseller_uses] > Order Type BO Billing Order (SO Sales Order) > Order Flow Transitions
(PBA-E 5.5 and later)
or
Configuration Director > OrderProcessing > All Order Flows > [order_flow_that_reseller_uses] > Order Type BO Billing Order (SO Sales Order) > Order Flow Transitions
(PBA-E 5.4 and earlier).
Default transition for the Billing Order from the New status:
From Status Action Success Fail Transition Type
New Open order WC NW On Event
Default transition for the Sales Order from the New status:
From Status Action Success Fail Transition Type
New Cancel Order CL NW Manual
New Open Order OP HL Auto
If transaction types are different, they were changed manually and should be set back.