Symptoms

A billing order was not generated on the statement cycle date defined.

An example:

  • a customer has an account statement day set to the 1st day of month;
  • the customer's subscription has billing period type set to Monthly on Statement Cycle Date. In this case this means that subscription is billed monthly on the date of statement cycle which is the 1st day of month;
  • billing order was generated not on only on the 1st day of month, but also on another day of the same month.

Such situation happens every month and causes two billing orders in a month for a single subscription (both for periods shorter than one month, one order is created on the statement cycle day, the other on the subscription expiration day).

Cause

The subscription was not renewed in time, therefore on the correct billing date (statement cycle date, 1st day of the month) the system could not set the next subscription billing date to the 1st day of the next month (as the subscriptions expiration date is earlier than the 1st day of the next month). So, the system had to set the next billing date to the date equal to the subscription's expiration date. On this date (the subscription may have been already renewed) the system bills the subscription. On the next statement cycle (the 1st day of the next month), the system bills the subscription again (which is correct, as billing is set to Monthly on Statement Cycle Date). If the subscription's expiration date is again in the same month (earlier than 1st day of the next month), then the same situation happens.

Resolution

There can be several ways to fix an issue (to have a single billing order for a subscription):

  1. Change Billing Period Type from Monthly on Statement Cycle Date to Fixed Number of Month in the plan configuration. In this case billing order will be generated every month on a day of month when subscription was started. Subscriptions synchronization with option Update Subscription Prices is required for an option change to be propagated to existing subscriptions.
  2. Set the auto-renewal in the service plan to the setting 31 day Before Expiration. This will avoid late renewals. Subscriptions synchronization with option Update Subscription Service Terms is required for an option change to be propagated to existing subscriptions.
  3. Use 1 Year subscription period, switch existing subscriptions to this period. In this case billing orders will be created only on the statement day every month, except for the case in the end of subscription period once a year, but that can be avoided by applying option 2.

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