Symptoms

APS task "Executing configuration script" fails with errors like:

getaddrinfo failed: Name or service not known
failed to open stream
failed to load external entity

or

failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.

Cause

Script execution fails because provisioning gateway server cannot connect to endpoint for communication with external system because of several possible reasons:

  • cannot resolve hostname
  • external provisioning system does not respond

Resolution

  1. Make sure you specified correct APS server endpoind hostname in APS package properties (or in Application's "Application" class resource).

  2. Determine the endpoint`s hostname, for example for Backup Agent APS

    a. Check BackupAgent endpoint`s hostname is specified in "BA internal host" parameter in APS settings.

    b. Or check task error output:

    Warning: SoapClient::SoapClient(https://backupagent.provider.net/BackupAgentServices/BAWebService.asmx?WSDL): failed to open stream: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.
    in C:\Program Files\SWsoft\PEM\APS\instances\684\scripts\baws\soapclient.php on line 55
    

    Endpoint hostname here is backupagent.provider.net.

  3. Login to the OA provisioning gateway server and check availability of the BackupAgent endpoint:

    # wget https://backupagent.provider.net/BackupAgentServices/BAWebService.asmx?WSDL
    --2014-07-18 05:56:45--  https://backupagent.provider.net/BackupAgentServices/BAWebService.asmx?WSDL
    Resolving backupagent.provider.net... 11.22.33.44
    Connecting to backupagent.provider.net|11.22.33.44|:443... failed: Connection timed out.
    Retrying.   
    
    # telnet backupagent.provider.net 443
    Trying 11.22.33.44...
    telnet: connect to address 11.22.33.44: Connection timed out
    

    With results like above DNS and Internet connectivity settings of the provisioning gateway should be checked. If they are ok, make sure that BackupAgernt server is running and reachable from the network.

Internal content