Symptoms

The customer order should have received promotion (by promo code or global). But when you check order later the promotion was not applied.

Cause

  1. Promotion was created after order was placed.

  2. Promo Code is incorrect.

  3. The applicability condition was not satisfied. Please check Home > Products > Marketing > Promotions > Promotion Name in PBA-E 5.5.x and later or Home > Product Director > Marketing Manager > Promotions > Promotion Name in PBA-E 5.4.x and earlier:

    Applicability Condition is a regular expression, if it is satisfied (returns true) promotion is applied, if not - not applied. In promotion conditions it is possible to use only placeholders based on service parameters of subscriptions (@@ParameterID@).

  4. Promotion is not expected to be applied to such kind of orders. E.g. if a promotion is Applicable To Sales - No, Applicable To Renewal - Yes, it will not be applied to the sales orders, only to the renewals

  5. If you see the promotion settings that the number Subscription limit is equal to the Promoted Subscriptions, it means that no more subscriptions can be purchased with this promotion, as the limit is exceeded.

  6. The setting Per Customer Limit is specified and the customer already used this promotion.
  7. The promotion is of type "By Parent Plan".
  8. The subscription has option Freeze Prices set to Yes: That means that neither promotions nor discounts are valid for this subscription 
  9. Incorrect Service Plan ID / Resource ID set in the Promotion.
  10. Unsupported in REST API (Order Management) on any CH or RN Orders, Classic CP uses internal (non-REST API) to set up promo code on plan change.

Resolution

  1. Verify that promotion was created before order was placed.
  2. Verify that promocode is correct. Please check the article #8304.

  3. Either correct applicability condition or remove it if it is incorrect/not needed.
  4. Correct the applicability if required or inform the customer that the promotion was not applied because is not supposed to be applied for such order types.
  5. Increase the subscription limit in the promotion settings.
  6. That is by design, you can increase Per Customer Limit, if required.
  7. Refer to kb #125560.
  8. Disabling the option Freeze Prices set to No
  9. Ensure the correct Plan ID / Resource ID are set in the Promotion

Internal content

Link on internal Article