Symptoms

User with "COMMUNIC_VIEW_MSG_LOG" privilege cannot see "Message log" menu.

Cause

Since PBA 5.5, menu has been moved to a screen which requires higher privileges.

Resolution

  1. Login to PBA application server

  2. Create /usr/local/bm/customization directory where customization files are to be stored:

    mkdir /usr/local/bm/customization
    
  3. Create symlink in conf/wnd/<container_name>/customization directory that points to /usr/local/bm/customization directory:

    cd /usr/local/bm/conf/wnd/<container_name>/customization
    ln -s /usr/local/bm/customization customization
    
  4. Create folder

    $PBA_ROOT/conf/wnd/MESSAGE/customization/customization/
    

    replace $PBA_ROOT by path to PBA home directory.

  5. Create file "MainClass_NewSystemSettingsNewMenu.xml" in this directory, making sure that pba user has permissions to read the file.

  6. Put the following content into the file:

    <window id="MainClass_NewSystemSettingsNewMenu">
      <elements>
        <href id="sys_set_system_message_log" value="Message Log" icon="images/nav/tree/ConfigurationDirector/EventManager/EventLog-16.gif">
      </elements>
      <actions>
        <ref id="sys_set_system_message_log">
          <call type="window" callee=MESSAGE::EmailMessage_EmailMessageList()/>
        </ref>
      </actions>
      <layout>
        <grid id="sys_set_operations_iconpanel">
          <row id="sys_set_system_message_log" after="sys_set_operations_helpdesk">
            <cell id="title">sys_set_system_message_log</cell>
            <cell id="description">``</cell>
          </row>
        </grid>
      </layout>
    </window>
    
  7. Restart Stellart www service.

  8. New menu "Message log" will appear if one clicks on "System" in the "Operations" section.

Internal content