Symptoms

"Loading" is not localized in the online store when you click for additional information about the resources or service plans (question mark or exclamation mark):

Cause

The issue is caused by the bug with id #PBA-56555 ("Loading is not localized in store").

Resolution

The bug is fixed in BA 6.0.

To workaround an issue in BA earlier than 6.0 follow the steps below:

  1. Edit the file usr/local/bm/templatestore/webroot/static/js/async.js on the store server, substitute

    el.innerHTML = "Loading...";
    

    with

    el.innerHTML = locale["LOADING"]; 
    
  2. Synchronize the store
  3. Clean browser cache

As a result, the translation will be taken from the appropriate store dictionary. A workaround is to be reapplied after each BA update installation.

Internal content