Symptoms

Order is stuck in No Payment Method Attached (Sales, Renewal, Upgrade) or in New (Billing) status. When clicking buttons Create Invoice or Create or Assign Payment the following error appears:

Error: Table Payment Methods Processing Option doesn't contain row with id Int32(NULL)

Daily Billing on the account fails with the same error message:

[14-05-19 04:01:01.940 Worker2.45  TH10163 ERR] Daily Billing Process on Account #ID failed with exception: Table Payment Methods Processing Option doesn't contain row with id Int32(NULL).

Cause

Payment method that was marked as default for the account, was deleted from Home>Configuration Director>E-Commerce Settings>Payment Methods Processing , but payment method is still marked as default for client in PBA database. The issue was reported to PBA developers in the internal request PBA-51063 and will be fixed in future versions of PBA.

Resolution

Selelct another payment method as default in Home > Operation Director > Account Manager > Customers > [AccountID] > Payment Methods.

Internal content