Symptoms
Payment via ASSIST fails with the error:
Can't get transaction details: invalid response received. Please check the payment status using ASSIST Control Panel.
The following info is shown in ASSIST.log:
[14-05-07 17:56:04.287 Worker1.7 RQ26550 TRC] +++[2] Str AssistAPI::doRequest(const Str&, const Str&)()
[14-05-07 17:56:04.287 Worker1.7 RQ26550 NTE] request = https://payments.paysecure.ru/orderresult/orderresult.cfm. POST: Merchant_ID=772265&Login= [login]&Password=***&Ordernumber=6_139947091248405&Format=3
[14-05-07 17:56:04.442 Worker1.7 RQ26550 TRC] ---[2] Str AssistAPI::doRequest(const Str&, const Str&)
Cause
Thers is space at the beginning of the login of ASSIST processing center configuration.
Resolution
Please go System > Settings > Payment Gateway > Payments Processing > ASSIST Processing Center
, click Edit
and remove space from the login.