Symptoms
Consolidated invoice was not created on statement date, but 1 day later. On statement day there is following error for account when daily billing is running:
Daily Billing Process on Account #1014528 failed with exception: Payment amount should be greater than zero.
Cause
The following conditions are met:
Customer class of the account has the following settings:
Auto Apply Credits Yes
Billing Type Per Account
Statement cycle for the account has the following setting:
Day of Statement Source Per Account day (by default first Order day)
There is default payment method configured for account.
- There is open payment/credit memo that will cover whole invoice.
When invoice is created first already created payment is being assigned, but then PBA-E tries to create zero payment for the invoice and fails. Bug #PBA-53236 was submitted regarding the issue.
Resolution
The issue is fixed in PBA-E 5.5.4. Please upgrade to the latest version of PBA-E.
If upgrade is not possible please use one of the following workaround:
Create billing orders not simultaneously with invoice (statement cycle setting "Day of Statement Source")
Disable auto-payments on account
- Disable auto-apply credits