Symptoms

Customer goes to More Services > Databases in CP, selects any MySQL or PostgreSQL database and clicks "Browse database manager" link.

Database manager tool does not work and after few minutes 'service unavailable' error is returned.

E.g., following page is being loaded:

https://cp.domain.tld/phpmyadmin/638/

If we check the webspace's error log file on CP server, it shows these messages:

~# tail -fn0 /usr/local/pem/vhosts/100001/log/error_log
[Sun Dec 15 21:00:10 2013] [info] Subsequent (No.27) HTTPS request received for child 6 (server cp.domain.tld:443)
[Sun Dec 15 21:00:13 2013] [info] [client 1.2.3.4] (70007)The timeout specified has expired: SSL input filter read failed.
[Sun Dec 15 21:00:13 2013] [info] [client 1.2.3.4] Connection closed to child 8 with standard shutdown (server cp.domain.tld:443)

Diagnostics

On the CP server, check the contents of this file:

/usr/local/pem/vhosts/100001/webspace/httpsdocs/cp.domain.tld/.branding_htaccess

it should contain rewrite rules for the corresponding services:

RewriteRule ^phppgadmin/547/(.*)$ https://anotherdomain.tld:9114/$1 [P]
RewriteRule ^phppgadmin/636/(.*)$ http://2.3.4.5:9114/$1 [P]
RewriteRule ^phpmyadmin/638/(.*)$ http://2.3.4.5:9113/$1 [P]

Cause

Needed ports are closed on the PHPMyAdmin and PHPPGAdmin servers. Most probably these pages from deployment guide were not followed:

Resolution

Make sure it is possible to establish the needed network connections from both the CP server and from outside. For the above example the commands will be:

# telnet anotherdomain.tld 9114
# telnet 2.3.4.5 9114
# telnet 2.3.4.5 9113

If the connection times out, ask your network administrator to create necessary firewall rules.

Internal content