Symptoms

Attempt to switch the service plan for the subscription from the providers control panel by clicking [Switch Plan] on the subscription screen results in the error message:

Can not switch Plan for Subscription #XXXXXX: there is no Plan to switch to for this Subscription. 

Cause

  1. "Allowed Upgrades/Downgrades" are not specified for the service plan the subscription is based on.
  2. The subscription owner belongs to the customer class with the option "Show Customers only Plans of this Class", but the configured upgrade plans are for different customer class.

Resolution

  1. PBA 5.4: PBA Home > Product Director > Plan Manager > Service Plans

    PBA 5.5 and above: Home > Products > Service Plans

    select the plan the subscription is based on and configure Allowed Upgrade/Downgrade. For details refer to the documentation. If you do not see the required plan in the list, refer to kb #114548.

  2. Either disable the option "Show Customers only Plans of this Class" for the customer class or change the customer class on the service plan(s) configured for upgrade.

Internal content