Symptoms

  1. In the provider's control panel (PCP) the redirect payment method was set to be used for auto payments, but in the customer's control panel (CCP) in Parallels Panel > Account > Payment Methods it is shown Auto Payments Off.
  2. The status of Auto Payment for the redirect payment method is different in the list of the payment methods in the PCP or CCP (set to Off) and in its details (set to On).

  3. Clicking the "Enable Auto Payments" button in the redirect payment settings from the CCP results in the message: <Payment Method> will be used for Automatic Payments, Auto Payments is set to "On" in the method details, but in the list of available payment methods in CCP it still has "Auto Payments - Off". Meanwhile information in Parallels Panel > Account (Payment Methods section) is changed.

Cause

On the screens

PCP Home > Operations > Payment Methods

CCP Parallels Panel > Account > Payment Methods

Auto Payments is always "Off" for the external redirect methods. The issue is considered as a bug #PBA-30701.

Basically, there is not much sense in making the redirect methods be used for autopayments - the payment will be created but not processed as additional actions are required ("Pay Now" button shall be clicked).

Internal content