Symptoms
- PBA 5.4.x
- PBA-E shows one-hour difference between the server time and the time in the provider's control panel (events, task log, etc). The database time corresponds to the PBA server time.
Moscow timezone is configured on the application server:
[root@billing ~]# ll /etc/localtime lrwxrwxrwx 1 root root 33 Nov 21 16:14 /etc/localtime -> /usr/share/zoneinfo/Europe/Moscow
Cause
Incorrect time handling (most probably after the daylight saving time abolishement).
Resolution
Upgrade PBA installation to PBA 5.5.x.
If upgrade is not possible at the moment, use a workaround - change the timezone to a different with the same time shift, e.g. Asia/Dubai.