Symptoms

When customer turns on RAM Autoscale for particular container this operation is failed with error in poa.debug.log:

Failed to initiate autoscale for VeId [customerId=<CUSTOMER_ID>, name=<NAME>]: P50019: RAM size cannot be changed in the STARTED state

Issue can be reproduced in following way:

  1. A lot of VEs were created on the server (to fill the RAM).
  2. Memory consuming script is started inside a VE.
  3. snmpd service will be in top with 100%.

Cause

snmpd is killed by OOM killer due to the script execution in virtual machine. This issue was escalated to Maintenance Team with ID CCU-7262.

Resolution

Please contact your account manager to clarify additional details regarding CCU-7262.

Meanwhile, as a workaround, a script to restart snmpd service automatically in case of failure could be applied to PACI hardware nodes:

~# cat d.sh
#!/bin/bash

mkdir -p /root/scripts
cat > /root/scripts/snmpwatch.sh <<EOF
#!/bin/bash

res=\`service snmpd status\`
res1=\$?

if [ "\$res" == 'snmpd dead but pid file exists' -o \$res1 -ne 0 ]; then
        date >> /root/snmpdrestart.log
        echo "SNMPD in dead state was detected"
        /etc/init.d/snmpd restart
fi

EOF

~# chmod +x /root/scripts/snmpwatch.sh
~# echo '* * * * * root /root/scripts/snmpwatch.sh' >> /etc/crontab
~# service crond restart

Internal content